Low risk of breaking in future versions