Medium risk of breaking in future versions